10 Tips to Get 100% Site Health Score in WordPress 5.2

dailydose
#25

here they fixed it…
Hello Shourav,

I am following up on your case in order to let you know that the reported issue has been successfully resolved. It appears that the issue was related to the wp-includes folder. The core files in the mentioned folder were old which result in the error on the home page.

By the time you are reading this reply, I have deployed a new wp-includes folder from a clean WordPress application. Once that has been done the WordPress started loading normally on my end. Note that the Imagick is currently enabled.

I think this should be helpful!

#32


Please tell me solution of this.
what to do to solve it.
@GulshanKumar

#33

I will try to answer. Can you please provide some information first?

Steps


  • Go to “Info” Tab
  • Click “Copy site info to clipboard”
  • Paste here to share with me.

I need to analyze.

1 Like
#35
### wp-core ###

version: 5.2
site_language: en_US
user_language: en_US
permalink: /%postname%/
https_status: true
user_registration: 1
default_comment_status: open
multisite: false
user_count: 8
dotorg_communication: true

### wp-paths-sizes ###

wordpress_path: /var/www/example.com/htdocs
wordpress_size: 1.72 GB (1845189714 bytes)
uploads_path: /var/www/example.com/htdocs/wp-content/uploads
uploads_size: 141.49 MB (148362856 bytes)
themes_path: /var/www/example.com/htdocs/wp-content/themes
themes_size: 11.77 MB (12339629 bytes)
plugins_path: /var/www/example.com/htdocs/wp-content/plugins
plugins_size: 69.52 MB (72899534 bytes)
database_size: 71.82 MB (75313241 bytes)
total_size: 2.01 GB (2154104974 bytes)

### wp-dropins (2) ###

advanced-cache.php: true
object-cache.php: true

### wp-active-theme ###

name: Child Theme
version: undefined
author:example
author_website: https://example.com/author/example./
parent_theme: Genesis
theme_features: menus, post-thumbnails, title-tag, automatic-feed-links, body-open, genesis-inpost-layouts, genesis-archive-layouts, genesis-admin-menu, genesis-import-export-menu, genesis-readme-menu, genesis-customizer-theme-settings, genesis-customizer-seo-settings, genesis-auto-updates, genesis-breadcrumbs, genesis-menus, genesis-structural-wraps, widgets, html5, genesis-accessibility, genesis-responsive-viewport, custom-background, genesis-after-entry-widget-area, genesis-footer-widgets, genesis-post-format-images, post-formats
theme_path: /var/www/example..com/htdocs/wp-content/themes/genesis

### wp-themes (2) ###

Genesis: version: 2.10.1, author: StudioPress
Twenty Nineteen: version: 1.4, author: the WordPress team

### wp-plugins-active (22) ###

404 to 301: version: 3.0.4, author: Joel James
Ad Inserter: version: 2.4.16, author: Igor Funa
AdSense Invalid Click Protector: version: 1.2.2, author: Saumya Majumder
Akismet Anti-Spam: version: 4.1.1, author: Automattic
Anti-spam: version: 5.4, author: webvitaly
Classic Editor: version: 1.5, author: WordPress Contributors
Cloudflare: version: 3.3.3, author: John Wineman, Furkan Yilmaz, Junade Ali (Cloudflare Team)
Fix Rss Feeds: version: 3.1, author: flyaga li
Google Analytics Dashboard for WP (GADWP): version: 5.3.8, author: ExactMetrics
Nginx Cache: version: 1.0.4, author: Till Krüss
OneSignal Push Notifications: version: 1.17.3, author: OneSignal
Really Simple SSL: version: 3.1.5, author: Rogier Lankhorst, Mark Wolters
Redirection: version: 4.2.3, author: John Godley
Redis Object Cache: version: 1.4.3, author: Till Krüss
Reduce Bounce Rate: version: 4.3.1, author: Okoth1
Table of Contents Plus: version: 1601, author: Michael Tran
TablePress: version: 1.9.2, author: Tobias Bäthge
UpdraftPlus - Backup/Restore: version: 1.16.14, author: UpdraftPlus.Com, DavidAnderson
Webcraftic Clearfy – WordPress optimization plugin: version: 1.5.3, author: Webcraftic <wordpress.webraftic@gmail.com>
WP Revisions Control: version: 1.2.1, author: Erick Hitter
 Star Ratings: version: 2.6.4, author: Kamal Khan
Yoast SEO: version: 11.1.1, author: Team Yoast

### wp-media ###

image_editor: WP_Image_Editor_Imagick
imagick_module_version: 1687
imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
imagick_limits: 
	imagick::RESOURCETYPE_AREA: 122 MB
	imagick::RESOURCETYPE_DISK: 1073741824
	imagick::RESOURCETYPE_FILE: 768
	imagick::RESOURCETYPE_MAP: 512 MB
	imagick::RESOURCETYPE_MEMORY: 256 MB
	imagick::RESOURCETYPE_THREAD: 1
gd_version: 2.2.5
ghostscript_version: 9.26

### wp-server ###

server_architecture: Linux 4.15.0-44-generic x86_64
httpd_software: nginx/1.14.1
php_version: 7.2.17-0ubuntu0.18.04.1 64bit
php_sapi: fpm-fcgi
max_input_variables: 1000
time_limit: 300
memory_limit: 256M
max_input_time: 60
upload_max_size: 50M
php_post_max_size: 50M
curl_version: 7.58.0 OpenSSL/1.1.1a
suhosin: false
imagick_availability: true

### wp-database ###

extension: mysqli
server_version: 5.5.5-10.3.12-MariaDB-1:10.3.12+maria~bionic-log
client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $

### wp-constants ###

WP_HOME: undefined
WP_SITEURL: undefined
WP_CONTENT_DIR: /var/www/example.com/htdocs/wp-content
WP_PLUGIN_DIR: /var/www/example..com/htdocs/wp-content/plugins
WP_MAX_MEMORY_LIMIT: 256M
WP_DEBUG: false
WP_DEBUG_DISPLAY: true
WP_DEBUG_LOG: false
SCRIPT_DEBUG: false
WP_CACHE: true
CONCATENATE_SCRIPTS: undefined
COMPRESS_SCRIPTS: undefined
COMPRESS_CSS: undefined
WP_LOCAL_DEV: undefined

### wp-filesystem ###

wordpress: writable
wp-content: writable
uploads: writable
plugins: writable
themes: writable
mu-plugins: writable

#36

Thanks for providing information.

  • Consider disabling this one “Webcraftic Clearfy – WordPress optimization plugin” and checking Site Health again.
3 Likes
#37

ok sir

#38

@GulshanKumar where is 4th Tips :nauseated_face:

#39

Oh, I missed and I have added one in the last, not to disable rest API.

3 Likes
#40

The issue is still same
@GulshanKumar

#41

Okay, please disable your plugins one by one to check. Also, make sure there is nothing such added in the Theme functions.php file.

1 Like
#42

I checked it. This issue is something in the theme
But how to identify it?

#43

Risky Steps, please take backup before proceeding. I won’t be responsible and may not support if any issue arised. Proceed at own risk if you know what are you doing.

.
.
.
.
.


  1. Go to Theme Editor
    image
  2. Check Child functions.php file
    image
  3. Do check for Parent Theme also
    image
  4. If by chance you have added any snippet to disable update checking, you can remove it to fix the issue.
2 Likes
#44

Cannot find anything

1 Like
#45

Okay, fine. To further debug, can you paste last 5 lines (from bottom) of wp-config.php file?

You can find wp-config.php file using SSH at below location

nano /var/www/example.com/wp-config.php
1 Like
#46

The optional module, fileinfo, is not installed, or has been disabled
The optional module, imagick, is not installed, or has been disabled.

Those two error were showing
I created php.ini file and write below code
extension=imagick.so
extension=php_fileinfo.dll

But still those recommendation are showing

#47

Please check with hosting team. It could be they need to restart PHP server from their end.

#48

PHP modules perform most of the tasks on the server that make your site run. Any changes to these must be made by your server administrator.

The WordPress Hosting Team maintains a list of those modules, both recommended and required, in the team handbook (opens in a new tab).

  • Warning The optional module, bcmath, is not installed, or has been disabled.
  • Warning The optional module, exif, is not installed, or has been disabled.
1 Like
#49
define('WP_DEBUG', false);

define('WP_REDIS_SELECTIVE_FLUSH', true);
define('WP_CACHE_KEY_SALT', 'redis_object_cache_for_wp_example.com');
/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
        define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');
#50

That appears normal to me. There is no problem with wp-config.php file.
There are many ways through update can be disabled silently. Change your theme and check again!

1 Like
#51

Hello how can i fix this?


This showed up recently!