Anyone Resolved Ezoic Origin Error

Hello guys, anyone who is using Ezoic has faced the Origin Error issue. So, anyone resolved it? I am getting the same issue and still not resolved yet from the Ezoic support team. If anyone has a solution then please help me. Thank you.

Login to Ezoic > Speed > Caching > Enable CDN caching

  • Check HTTP response and confirm there is HIT response in the incognito instead of MISS.

Thank you very much for your response #Gulshan. I had already enabled the CDN caching. As per your suggestion, I have checked the HTTP response in both window (incognito and main window). The first time, it was MISS in the response. Then, I tried again then it was HIT. Similarly, I tried in the main window as well and I got the HIT response. So, would you clarify what it means if the response is HIT or MISS?

This is my blog URL Programming Fields, if you can take a look then I will be very thankful to you.

That means all is working fine. If you countinue facing origin issue, it could be that origin server is taking longer to respond (roughly more than 30 seconds). Upgrading server may help.

MISS indicates response was fullfilled via origin server.

Visitor > Ezoic IP > WordPress Origin server IP

HIT indicates response was fullfilled via Ezoic server itself. This reduced load at origin.

Visitor > Ezoic IP

I have already upgraded the hosting from shared to VPS. Also, I have whitelisted the Ezoic IP Addresses. But, still, I am getting the same issue. I raised several tickets to the Ezoic Support Team. Still, the ticket is opened and processes are going on at the Ezoic end.

Do you see any log?

When this error appears, can you access your site directly over origin IP?

image

Gulshan, I want to ask one more thing from you. When the Ezoic ads are loading the site loads very slowly. As per the GTMetrix, the performance is very low, even the hosting is VPS of the Namecheap with 40GB and 2GB RAM.

So, how can we optimize it?

Didn’t try over the Origin IP. Next time, I will try. Thank you for the suggestion.

It’s completely normal because advt increases web page size (making 1MB+) and their server response time is slow as well.

You’re welcome!

Thank you very much for your response.

Hi Gulshan,
As per your suggestion, I have checked the page source (Ctrl + U) when the site was showing the Origin Error .

I tried accessing the site using the IP Addresses showing in the source.

And I was able to access it. Similarly, with the second IP Address with TCP port.

So, can you analyze this one?

How you connected ezoic?

Avoid Namecheap. Use another reputed VPS company such as VULTR where you’ll have better control over your server.

I have connected using Cloudflare.

Next time I will try Vultr.

Finally, the Origin Error is resolved. It was the SSL issue at the origin server. The Ezoic team had set out with SSL at their end. But at the origin error SSL was not installed. So, that was the misconfiguration issue.
Thank you all.

Did they installed Origin SSL at your Namecheap hosting cPanel or just changed settings inside Ezoic Dashboard?