Anyother way of getting free SSL instead of Let's encypt and cloudflare?


#1

I getting an error while trying to install SSL using Let’s encypt.

The error is too many certificates already issued to the domain.

I have tried to install WordPress many times because I was learning and I am new in these things.

That’s why it is showing error, I am also using Cloudflare and enable flexible SSL, I have enabled in 9 hours ago but still not getting https.

Is there any other method or how can I use already issued SSL certificate?the


#2
  • Did you updated Cloudflare Nameservers? You need to do it first.

  • Go to Cloudflare > Select domain > Overview page > Make sure it’s active instead ‘Paused’.

  • Go to Cloudflare > DNS > Turn on Orange cloud for the following two records. If it’s already, good.

A - domain.tld - ip - Orange Cloud
CNAME - www - domain.tld - Orange cloud
  • Wait 5 minutes, check your domain www, and non-www A record IP at DNS checker, resulting ip should start from 104. Or, open CMD and enter below command.
ping domain.tld

Check reply IP.

  • Ok, assuming at this point Cloudflare is enabled.

  • Now it’s time to ensure Cloudflare SSL is active or not.

  • Go to Cloudflare Crypto > Enable Flexible SSL.

Let me know what happens after these all steps.

For more information, please search our forum. There are many tutorial on this subject.

Here’s one

How to Setup Free Cloudflare CDN for Wordpress (Tutorial)?


#3

Thanks, @GulshanKumar!

I am following your steps and let me know about the results.


#4

I would recommend start from reading above basic guide first. As it seems missing so much details in the question.


#5

Ok, I will follow above guide too


#6

You’re welcome!


#7

Doing so, Stop my site loading, it is showing error ** Error code: SSL_ERROR_NO_CYPHER_OVERLAP **


#8

Okay… Is it https://www.staymeonline.com domain in question?


#9

Yes, It is


#10

You need to wait for approximately 1 hour (DNS TTL).

As Nameservers update is in the progress.

https://dnschecker.org/#NS/www.staymeonline.com

Rest, looks ok.


#11

I didn’t change the name servers it was already pointed to cloudflare.

Tell me one this, I have installed three domain on same server, staymeonline.com is redirected to my another domain see here https://sslanalyzer.comodoca.com/?url=staymeonline.com


#12

Solution :arrow_down_small:

To enable HTTPS,

  • Login to Cloudflare > Select domain > Overview image

  • Advanced Actions > Make sure Cloudflare is enabled on site.
    image

  • Go to DNS menu > enable Cloudflare DNS and Proxy for the following two records: A and CNAME by keeping Orange Cloud instead Grey.


A record - staymeonline.com - Server IP - cloudlfare_orange

CNAME - www - staymeonline.com - cloudlfare_orange

An example this is how you need to keep your DNS status.

The problem should be resolved now.


#13

#14

This topic was automatically opened after 5 hours.


#15

Hello,

@Dixravi Were you able to resolve the problem?

  • Yes, resolved.
  • Still, trying!

0 voters


#16

Your question is about

“Anyother way of getting free SSL instead of Let’s encypt and cloudflare?”

Ans: yes you can use zerossl.com to get a free trusted ssl certificate.


#17

Good to see this problem has been resolved now!


#18

Thanks to you


#19

You’re welcome!

What steps did you followed for fixing the issue? :smiley:


#20

I followed the steps you shared above… Want to know one more thing… Can we install WordPress and discourse both on same server ubuntu18.04?