Enabling gzip returns error 500

#1

I want to add gzip compression for my website to server it more faster to the visitors.I have set up gzip but after 2or 3 min get 500 error.
anyone help me to add gzip in my website
for youe kind information my website is at nginx server.
@GulshanKumar @AbhishekVerma help me if you can

0 Likes

#2

Please don’t use .htaccess method. It’s outdated approach which increase server load.

Just use Cloudflare, and they will do automatically from their end.

1 Like

#3

@GulshanKumar One question.
Say my siteground manager software is doing gzip for me and i also have it activated in cloudfare then can it be bad? increase server load or null effect?

0 Likes

#4

Less usage of .htaccess is better.

Ref: https://httpd.apache.org/docs/2.4/howto/htaccess.html#when

0 Likes

#5

This link seems to be for apache server
My server is nginx

0 Likes

#6

No worries. NGINX doesn’t provide .htacccess support. It has already fastest method available, NGINX configuration file which is generally accessible at /etc/nginx/sites-available/exampe-site if you have root access.

0 Likes

#7

@rajdeep According to me, CloudFlare is the best way to do it. It is quite easy.

0 Likes

#8

My hosting provider Installed Engintron On The Server, that’s why I cant use cloudflare.

0 Likes

#9
  • Have you tried to setup Cloudflare?
  • Did you received any specific error message or problem?
0 Likes

#10

error 500, when enable cloudflare.

0 Likes

#11

What was the setup process?

  • One click - cPanel
  • Manually, I had updated nameservers also

0 voters

0 Likes

#12

Clearly means,

Internal Server Error.

This can happen due to plugin or theme conflicts. In case if you have, avoid keeping similar features Plugins such as two cache plugin.

Solution

  1. Enable default theme
  2. Deactivate all Plugins, enable one by one and check.
0 Likes