Fix SSL Handshake error


#1

Hi @GulshanKumar, Congrats for this forum.

Do you have any idea how to fix SSL handshake error? Google search console showing https://domain.com/post-url/feed/ errors. I did not find any legit way to fix it on Google.

I checked some other sites which are using Cloudflare and it’s same for other sites too.

I also checked gulshankumar.net and here is the result: http://www.feedvalidator.org/check.cgi?url=https%3A%2F%2Fgulshankumar.net

Server returned [Errno 1] _ssl.c:510: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Are you getting Index coverage errors also in Search Console.? Should we fix it or simply ignore it.?

Regards,
Dinesh


#2

I don’t use RSS Feed. I have redirected it to the homepage.


#3

@Dinesh Are you using Cloudflare?


#4

Yes, I’m using.


#5

+1. This error exists on most sites with https. AndroidPolice(.)com recently implemented https and I tried testing their site. Their result was positive. See screenshot.

Guess we are missing something here. @GulshanKumar Bhai, what’s your thoughts on this?


#6

That’s why, I think. Disable it for a moment (If you have SSL supports at origin) and check again.

CF SSL is not supported on every platform.


#7

Is there an advantage/disadvantage of using/not using RSS feed?


#8

I want to rank just in Google, I don’t care about RSS feed. Because, my readers don’t use it. I am sure. It’s age of Email Newsletter, not RSS.

RSS Feed is helpful if you want to automate something like Autoshare of new post on Social Media, Email Newsletter, show latest post at third-party site, etc.

Else, there is no use. Please correct if I am wrong.


#9

Disabling Cloudflare should fix this issue but I can’t stop using it.

Cloudflare saves my lots of bandwidth. I started using Cloudflare because of this issue - https://ask.shoutmeloud.com/t/error-establishing-a-database-connection-digitalocean/40000 (and Cloudflare fixed it :slight_smile: )


#10

I also don’t need RSS Feed.

I’m getting /feed/ errors for many days (So I thought it’s maybe because I have disabled RSS Feed)

But even after enabling I got same issue.

Do you have any way to fix this feed errors after disabling Feed?


#11

It just an information in the Search Console what they found while crawling. That’s not an error.

If you are not using, be relax. :slight_smile:


#12

I am getting same error( SSL Handshake failed - 525 error). I disabled cloudfare but it did not help to solve the error…Wht to do… pls help…?


#13

Can you start a new topic with more details? I’m quite sure I’ve seen enough of these 525s that I may be able to help if you provide enough information.


#14

ok i will share a new post .