Google not showing my post even search with full title


Hello friends,
Recently google stop showing my new post in searching. I tried to index by fetch as google but nothing happens. I am searching with full title but google do not show . I am very upset. Please help me friends.


Same thing is happening with me today. My recent posts are not indexing even after fetching it.


same with me :frowning:




@DUGGU @Bingout @Saksham @Anoop You guys are not alone. Most, if not all, are facing this issue. I think there was a similar threads a couple of days ago. No matter how many times you fetch, nothing will happen. And there is no pattern on how long does it takes to index a page. It happens randomly. Sometimes 4 hours and other times even 9 to 10 hours. So, do not worry. It’s not something specific to you.


Luckily, my all posts are crawled


Good going! But how soon are your pages being crawled? Up until recently, all my posts used to crawl in minutes from I post them. Now they take couple of hours. That too not for all posts. Some are instantly indexed. But i can confirm that something is off.


I never analyzed, but I publish in the night (01 to 03 am) and In the morning after 9 am they all are crawled. Actually, I daily publish the article at same time.


Hmmm. When you publish today, make a note of when they get indexed, if possible.


Same here… Google is taking hours to index my URLs :pensive:


My 3 days ago published post not showing in search engine . I used to fetch as google all my new published post for 2,3 months. Now please help me sir


Anyone else ??? is there any way to index fast?? One of my post is still not indexed even after 12 hours :confused::open_mouth::pensive:


Same here… My posts are not getting indexed. :tired_face:


same here guys my urls are not showing even after fetching


Search blog post title

Things to do if Search Engine don’t display a post

  1. Please check Google Search Console. Is there any warning? Consider fixing it.

  2. Check WordPress reading settings, make sure discourage search engine check box is unchecked.

  3. Look for specific blog post source code, make sure there shouldn’t be noindex.

  4. Check your robots.txt file. Is there URL Blocked?

  5. Are you suddenly getting spam backlinks? Please do audit.



It’s indexing but after 10-12 hours. Previously, this process was of minutes. But in March…:pensive:. Is there any way to index fast?


I have Follow Your Advice And Now My Post Indexed And Showing In Search Engine. Thanks Once Again Sir


How to solve server error?? @GulshanKumar (wp-content/themes/Newspaper)


Any update regarding issue. Pages are not indexing quickly. writing trending posts will be next to impossible without resolving this issue.


There’s nothing you can do about this.

Make sure all technical things are correct and then the indexing will depend on your site update frequency and site authority.