[Guide] How to Setup W3 Total Cache Plugin?

dailydose

#85

@gulshankumar I have installed, activated and configured this plugin in my test domain!

Issue: Whenever I am making any changes in any other plugins like “One Signal” etc. or even enable and disabling “Avatar Display” in “Discussion Settings”, I need to do “purge cache” for page cache in W3TC.

Then only the changes are taking effect! Is this expected?


#86

If W3TC prompt “Empty Page Cache”, it doesn’t do automatically but suggest you that if you need you can.


(Unavailable in this forum and other all social medias till 20th ) #87

How to find cdn path or is it possible to do it without selecting generic mirror option?


#88

@BLOGGING_SURGEON After selecting generic mirror, you can integrate a cdn.example.com with CDN option.


(Unavailable in this forum and other all social medias till 20th ) #89

If i type cdn.gulshankumar.net it redirects to this forum. Can you explain me why?


#90

For a while, I had implemented CDN at HGK. Later, I changed my mind and reverted back. So, I added 301 redirect from the old to new path.


(Unavailable in this forum and other all social medias till 20th ) #91

Okay sir :slight_smile: Thanks


#92

You’re most welcome!


(Rajput Moderator) #93

hehe! can you please export your W3TC settings and send it to me if possible? :yum:


#94

Haha. :heart_eyes:

I don’t use any cache plugin. I have custom configuration. So, cannot right now. Sorry :frowning:


(Suprim Shrestha) #95

I use wp fastest cache. Works perfect for me.


#96

@Paritosh I would recommend two things for you…

  1. Choose a plugin that supports Varnish. A stupid simple is Breeze.
Warning (don't enable its Browser cache) rest everything is perfect and automated.

  1. Go to Cloudways > Server > Manage Services > Enable Varnish

Expected: Amazing performance.


(Rajput Moderator) #97

Thank you :blush: I will try it and will report back.


#98

You’re welcome!! :slight_smile:


(Saksham Kumar) #99

I just installed this plugin in a new site and it is showing this error on top…

public_html/wp-content is write-able. When finished installing the plugin, change the permissions back to the default: chmod 755
public_html/wp-content. Permissions are currently 775

What to do? @gulshankumar


(Amit Tiwari) #100

please Clarify with Cloudflare optimal settings.


#101

I would prefer ignoring those error warning.


#102

For Cloudflare, here’s the guide


(Amit Tiwari) #103

One more thing Shout i Active Cloudflare Extension


#104

It’s not required.