Gutenberg and Theme/Plugins compatibility


#1

WordPress 5 with Gutenberg is now available. It’s important for us to make sure that our themes and plugins are compatible with Gutenberg.

In this thread, share the Gutenberg compatibility updates from your theme or plugin developer.


#2

Newspaper theme and Gutenberg compatibility:

The developers said that they are working on a update which will be released before WordPress 5 and it will fix all potential issues with Gutenberg.


#3

GeneratePress theme and Gutenberg compatibility:

GeneratePress 2.2 comes with full compatibility with Gutenberg Read more


#4

WooCommerce plugin and Gutenberg compatibility:

If you’re running WooCommerce, update to 3.5.1+ before updating to WordPress 5.0. Otherwise, the site may not work.


#6

Genesis and the StudioPress themes are compatible with the Gutenberg editor. Source


#7

#8

Newspaper Theme has been updated to version 9.2 with support for Gutenberg editor which is now available.

Full compatibility with Guttenberg and WordPress 5. We tested the theme with WordPress 5.0 Release Candidate to make sure that any problems are fixed on time for the next WordPress version.