How to instruct Google bot not to index any links in plugins?


#1

I have installed One Signal Push Notification on one of my blogs. I just accidentally made a site search in Google and I found one signal URLs was indexed? How to remove from these links from Indexing?
Also, is there any code to use for all plugins?
How to solve this issue?


How to Noindex OneSignal WordPress Plugin Directory?
#2

Go to Google Indexing > Remove URLs > Temporary hide. Submit the URL which you want to remove.


#3

I did this! It was removed! But the request is for only 90 Days.
How to tell noindex all URLs in Plugin folder of a Word Press site.


#6

Is this image correct bro?


#9

Currently, I added this link with Link Removal Request in Google Webmasters.
Will this code still? One more doubt, shall I use the same code for all the folders.


#10

You can keep added as safeguard to prevent from indexing.

You should only add that code for those folder which you want to keep noindex. It will work at directory level.

For example, if you add at location /wp-content/plugins/xyz/
whole /xyz/…/ folder and its internal urls will not index. Simple. :slight_smile:


#11

Thank you so much bro… @BihariLala @GulshanKumar


#12

What if I do this in wp-content/plugins/ folder? :thinking:

Will it de-index all plugins files from search engines? :thinking:


#13

Exactly. It will set noindex for all files for plugins directory and internal files.

example.com/wp-content/plugins/... (all in noindex) :smiley:

But, why would you prefer this option? Just curious to know! :thinking:


#15

What can possibly go wrong if I do that? :thinking: :sweat_smile:


#16

I am too watching this! Any updates friends.