How to stop Google from indexing UTM parameter in URL?

I’ve noticed some strange behavior in the search results. How to stop indexing links for our website that include UTM campaign parameter tracking. I created RSS Feedburner id and added into the widget in theme.

From that day, I’m noticing that Google is indexing both the original version of the URL and the following: example.com/?utm_source=rss&utm_medium=rss&utm_campaign=

I deleted the RSS id and subscription widget from the theme. But still, this type of URL is getting indexed for new posts. I’m using Rank Math plugin. It automatically adds the Canonical URL. So, how can I solve this UTM parameter tag issue ?? Help @GulshanKumar

2 Likes

Redirect utm query string to the canonical version permalink via Cloudflare Page Rule.

If the URL matches

https://www.example.com/*?utm=*

Forwarding URL with 301 permanent redirect to

https://www.example.com/$1

I think this option is there in Google Webmaster.