HTTP still showing after installing SSL in Ubuntu 18.04


#1

I have migrated my wordpress website from shared host to digital ocean, everything is perfect. but my website is still opening in http and showing privacy error…

I have installed SSL as well but my website is not opening with https.

I have used these commands to install SSL in my ubuntu 18.04 https://bmtechtips.com/install-free-ssl-certificate-digitalocean-apache2.htm

I have checked my website ssl status as well and it is showing positive result https://www.ssllabs.com/ssltest/analyze.html?d=staymeonline.com

can anyone tell me what is causing the erorr…


#2

You installed SSL only for Staymeonline.com while site redirecting to www.staymeonline.com. that’s why.


#3

So it wil be working, when I change my site from www to non www


#4

To fix, re-install SSL certificate for non-www and www both versions.


#5

i have installed for non www so now i only need to install for www.

only need to add www here…
letsencrypt --authenticator standalone --installer apache -d example.com

m i right?


#6

Thanks @GulshanKumar, for guiding me I did same as you told me now it will working


#7

Good to know, @Dixravi. You’re welcome!


#8

But now, I am seeing White death screen when login into my WordPress dashboard, can you tell me what is causing error and how can I fix that?


#9

What is the exact error message on the screen?

This is how you need to check

  • Go to Chrome > PressF12 > Network
  • Type your URL in the address bar, enter
  • let us know the HTTP status code.

#10

In the wp-admin, I am seeing totally bank white page. When I do what you told, I am seeing 500 internal error.


#11

I found this when I checked my Error.log file

[Tue Dec 25 06:53:34.503525 2018] [php7:error] [pid 25055] [client 103.208.152.86:52322] PHP Fatal error: Uncaught Error: Call to undefined method WP_Screen::is_block_editor() in /var/www/html/wp-includes/script-loader.php:2385\nStack trace:\n#0 /var/www/html/wp-includes/class-wp-hook.php(286): wp_common_block_scripts_and_styles(‘index.php’)\n#1 /var/www/html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)\n#2 /var/www/html/wp-includes/plugin.php(453): WP_Hook->do_action(Array)\n#3 /var/www/html/wp-admin/admin-header.php(97): do_action(‘admin_enqueue_s…’, ‘index.php’)\n#4 /var/www/html/wp-admin/index.php(100): include(’/var/www/html/w…’)\n#5 {main}\n thrown in /var/www/html/wp-includes/script-loader.php on line 2385


#12

Try to increase 'Memory Limit.


#13

In config file, Beause I have already increase my PHP memory limite to 30Mb when I was uploading database to PHPMYAdmin


#14

I increased memory limit in wp-config file and then it start getting

This page isn’t working

staymeonline.com is currently unable to handle this request.

HTTP ERROR 500

When I visit my wp-admin in starting it is showing your conection is not private(https error)…


#15

You do not have SSL certificate on that domain.

I would suggest re-installing setup properly.

If you need help, please check this guide

How To Install WordPress With LAMP/LEMP In Ubuntu 18.04


#16

No, I have installed SSL and setup is also installed properly.

I don’t think that I need to install it again…

My website is opening with https but wp-admin is showing https error and a black white page.


#17

It’s not loading … non-www version, says SSL error

www version is loading and wp-login.php is loading fine

https://www.staymeonline.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.staymeonline.com%2Fwp-admin%2F&reauth=1


#18

If you are trying to load in non-www version it is redirecting to www.

I know wp-login.php is loading file but after login in I am seeing white screen


#19

@Dixravi To fix this issue

  • Turn on debugging
define( 'WP_DEBUG', true );

to see the issue.

  • This can happens due to incompatible theme/plugin.

#20

In WP-config file… what to do next