I facing some problems in bitnami WordPress

#1

Hey, I am using Bitnami WordPress on GCP (apache server). And I am facing some issue plz help me to solve.

  1. .htaccesss file is not updating. - Whenever I try to edit .htaccesss file there is no message showing file is updated and also there is no impact of code. ( Means .htaccesss file is not updating or working)

  2. File permission error - I am unable to edit, upload, and create a file using SFTP(Cyberduck). Showing permission denied error.

#2

Why you switched to Bitnami? :man_facepalming:

#3

This is my new site hosted on GCP. I have no option.

BTW! Any solution and tell me which method is best for host WordPress site on GCP.

Can we Install WordPress with LEMP as we use method in Digital Ocean?

#4

If you access to cloud.google.com account and it has verified payment method,

Yes, you can install WP at Ubuntu 18.04 (x64) server.

Please see the guide

https://gulshankumar.net/install-wordpress-with-lemp-on-ubuntu-18-04/

#5

Hey, bro, I tried this method an hour ago. I faced some problem.:smile:
First I created VM instant with Ubuntu 18.04 operating system.

Then I clicked on VM instant >> SSH. (In short, I accessed the server via SSH)

And I started commanding. Unfortunately, It won’t ahead because at step #24 a command not working.

When I paste and enter the following command, it shows "access denied message"

sed -i ‘s/;cgi.fix_pathinfo=1/cgi.fix_pathinfo=0/g’ /etc/php/7.2/fpm/php.ini

#6

Try manually

First access as root

sudo -s

Then try manually

cd /etc/php/ && ls

Edit right version and change what you want, then must restart PHP.

#7

When? at the beginning or just before

cd /etc/php/ && ls

I would like to have you ever tried GCP, if yes which method did you use to install WordPress. And it was Nginx or apache?

#8

At beginning. Because GCP requires.

#9

Ok let me try plz stay online.

#10

Always NGINX. :heart_eyes:

1 Like
#11

Perfectly all right.

(sudo -s This command worked)

I am now just on #30. Install Let’s Encrypt SSL - But before I have some query.

At this movement, I can’t access the previous setup database. I mean after WordPress + LEMP get ready, I will have to install backup.

But you know I have no database. But at this movement, I can access WordPress dashboard so the ultradraft plugin will work for me?

#12

Dear Rushikesh, that’s correct. If you have backup with UpdraftPlus, you can restore your site.

1 Like
#13

Bro I tried to restore the backup. But site is crash :upside_down_face:

It looks like

And I am unable to login. Now I just have a backup file in my Google drive account.

Now???

#14

No worries. Please share your site URL. I will check it for you.

#15

I will share url in PM.

1 Like
#16

This issue is happening because WordPress site URL is wrong.

You need to replace
https://127.0.0.1/wordpress

to

https://example.com

Note: Do not add trailing slash at the end.

Steps

Follow below steps.

  • Edit wp-config.php file
  • Put below code
define( 'WP_HOME', 'https://example.com' );
define( 'WP_SITEURL', 'https://example.com' );

Note:

  • You should place above constant before that comment line where it says That’s all, stop editing…
  • I repeat, don’t add slash at the end of .com
  • Make sure the path should begins with HTTPS.

Save changes, your problem should be resolved now.

1 Like
#17

That was hard coding to indicate WordPress right URL.

Once you done above step, you will be able to login WordPress

  • Now, really do Search Replace to fix in the long term at Database level.

Please take backup before proceeding. In some cases, this step can break the website. Once, I faced this problem. So, you have been advised to be safe.

  • Now, you can remove that wp-config.php 2 lines code which you added in the earlier steps.
1 Like
#18

Ok It resolved

#19

Any plugin do you use?

#20

My all time favourite, and most trustworthy plugin: Better Search Replace :heart_eyes:

1 Like