I just restored my last website. But few errors

Im using Vultr. @GulshanKumar I used your LEMP source. It was really helpful.
Now I have just installed i uploaded my backup and restored it.
Now the problem was that I was not able to access my Editor due to SSL or redirection error. I saw it with the Inspect tool.

Then I installed Really Simple SSL. But then now I cannot log in to the backend due to redirection issues. I deleted the plugin from FTP. But the problem still exits.

I tried finding .htaccess, sadly cannot find it in FTP. Used force show hidden file. But then too cannot find it.

Now is there any other method to solve redirection problem.

PS. Let’s encrypt is installed as per the guide.

Okay Okay Okay!!! Found it!!!

You use this code in wp-config.php

//Begin Really Simple SSL Load balancing fix
$server_opts = array("HTTP_CLOUDFRONT_FORWARDED_PROTO" => "https", "HTTP_CF_VISITOR"=>"https", "HTTP_X_FORWARDED_PROTO"=>"https", "HTTP_X_FORWARDED_SSL"=>"on", "HTTP_X_FORWARDED_SSL"=>"1");
foreach( $server_opts as $option => $value ) {
  if ((isset($_ENV["HTTPS"]) && ( "on" == $_ENV["HTTPS"] )) || (isset( $_SERVER[ $option ] ) && ( strpos( $_SERVER[ $option ], $value ) !== false )) ) {
$_SERVER[ "HTTPS" ] = "on";
  }
}
//END Really Simple SSL

We don’t use .htacces in NGINX.

Perhaps, you may not need really simple ssl plugin because while deploying SSL it can forced that time.
Here’s the detailed guide

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.