My site is down. Please help

Siiteground support:
Hello, can you please check on my website https://guineapig101.com/ ?

It’s showing errors like these all the time:

Can you please check why that is? Thank you.

Reply:
Hello Shourav,

Thank you for contacting our Help Desk.

Currently I cannot reproduce the issue on our end. Still, I decided to check the server logs and statistics and see that why the problem occurred:

There are way too many executions generated from your index.php and admin-ajax.php scripts. The first thing you need to do is deactivate the WordPress Heartbeat process:

Doing so will help your site work properly thus avoiding the 504 timeout errors. Additionally, you are not using our Dynamic caching. It helps greatly in such situations so try it up:

Finally, go over our optimization guides:

Doing all of this should help you forget the error in future. If you still have issues you may consider upgrading your account to our GoGeek server as there we use advanced technology and the latest software designed for heavier websites.

I hope this clears things up.
If other questions appear, do not hesitate to get back to us.
We are always here for you.

Kind Regards,

Daniel Stoychev
Senior Technical Support

Can someone tell me what i need to do as everything went above my head. The server should handle traffic upto 25k while its down with just 7k
@GulshanKumar sir


I think some bots caused the issue?

How can the pages be so much when my actual traffic is 6000 pageviews only?

A host can handle more traffic when page cache remains properly configured else no way.

As WordPress is resource heavy, it is likely possible that your page cache might be missing and CPU usage went over limit.

Now here, enabling a cache plugin is not complete. In SG, I have seen a common problem for many sites that their proxy cache doesn’t work. It requires proper set-up.

If you go to cPanel > do you see SG cache for dynamic stuff enabled?

no i enabled it.
what is happening is i keep enabling it and it keeps getting disabled automatically.
both memcache and dynamic cache is getting disabled automatically. i tried configuring via cpanel. it shows it enabled while i see from sg site manager it shows disabled. dont know what just happened there.
never face such issue earlier.

Please do not struggle with this host. Kindly change it.

Here are few better option for you

  • If you value site up time, performance, great support, quick backup, premium experience, finally a peace of mind regardless of any cost, Kinsta is for you. This is a right choice for a serious business who need consistent performance and feel someone should be there to help quickly by fixing from their end instead providing instructions or plain scripted reply.

  • If you value performance, want everything in a limited budget, need some support also you can choose Cloudways. I use this host because perf and security is good. But I am not a huge fan due to their unhelpful documentation and slow response at chat.

  • If you don’t need any support and feel you are an expert like if site goes down or server get hacked, I can fix then choose Vultr. I like these guys, they are quick when it comes to support but soon they goes off and reply after some times. Alternatively, there is DigitalOcean, Linode almost same and great by performance but with ZERO support for the WordPress, you can get a little bit support only for server but not much.

1 Like


Here is the bot traffic do you find some issue here. I am suspecting the first one bot has some high crawl stats, can it be the issue? if yes how to fix the same?

From what I understand, Siteground NEVER uses per visit as calculation but CPU per second for resource Usage calculation. So as they see lots of executions site went down automatically.

To resolve, I don’t see any option except taking backup and resorting at Localhost or some other host.

1 Like

Traffic how much you receive, they never count. It’s all about CPU game, the more resources used site goes down.

Ultimately, this is called shared host. It’s being policy to keep big guys out of the system so they can fill small sites.

1 Like

got it? So will my site be up in a while? what could have caused that cpu uses spike?

You had Cloudflare enabled already so I highly suspect that bot is an issue!! Probably, it’s already covered.

I feel, bot things are just drama.

CPU usage can have spike due to various reasons

  • The more .PHP file gets executed likely to have higher cpu usage. Normally, in WordPress admin-ajax.php is the biggest offender for increasing cpu usage. Any plugin that uses often cause problem. Example of such plugin; any plugin which allow click to load, track visiors and post back to database, like that.
1 Like


I added this script in my theme. Will this help bring those down? will that break something as well?

You should keep Heartbeat API enabled inside Dashboard. Because there it’s required at so many places such as Post Editor.

If you disable for frontend, things like click to give 5 star rating for review such interactive things will not work.

Comment will continue to work. If you have simple plain theme, front-end should be fine.

1 Like

Please clear me one thing in simple:
To disable it, edit the functions.php file of your theme and paste these lines right after the opening <?php tag:

1

2

3

4 add_action( ‘init’, ‘stop_heartbeat’, 1 );

function stop_heartbeat() {

wp_deregister_script(‘heartbeat’);

}

This should completely disable this functionality and it will no longer add to the executions number and CPU time used in your account.
I just did it? should i remove it and do it via plugin? As i didnt get what you meant to say

Please keep it for a while till site doesn’t back up. Note: it may break dashboard inside features. Your frontend should be fine. I checked and noticed there is no usage for normal visiors at the moment.

My site seems up now. I already have 10 realtime visitors currently.
Should i remove it and add via plugin for smooth operations

Sure… Give a try

1 Like

Now this is a new issue which just showed up?


will it go down again?
Why it went that high suddenly. I already have cache enabled also i added the script as they said me to. I am going crazy now,

It’s a shared host. World’s limited form of host. They offer limited resources per account.

1 Like

How good is cloudways regarding the same issue.
I dont wanna get out of one and get to another pithole you know.
Thanks

1 Like