(Need Help) [Solved] Adsense ads not visible on pages with query strings in URLs

Hi,

I recently posted a major issue I have recently started facing . I already posted all the details here (https://support.google.com/adsense/thread/15136089?hl=en) on the Google Adsense Help Community, but no one seems to reply.

Can someone here help me debug the issue? Has anyone else ever faced this exact same problem?

Best regards,
Dhananjay Bhardwaj


Update (26 September)
Outcome: (Need Help) [Solved] Adsense ads not visible on pages with query strings in URLs

Same problem here.

May I ask you for what query string you want to show advt?

1 Like

Just checked, for me the ads are visible after trying a query string. Though not all of them. The one at the bottom completely is shown and the link ad

1 Like

@dhananjay Adsense Ads not showing in my site

1 Like

Ads are visible to me.

1 Like

Hi, thanks for the response.

Now please try adding a query string to the end of the URL, for e.g. “https://www.thecustomdroid.com/how-to-enable-dark-theme-gmail-android/?hshshd

You will see that the ads suddenly stop showing, however, if you check the page’s source code or use the Chrome’s inspect tool, you would see that the ad code is properly being injected.

@GulshanKumar Any words from you?

Solution: If you know any common query string as per Analytics report for example, there are fbclid automatically get added for link shared on Facebook, you can setup a redirect.

:warning: Caution: Not recommended if you do FB advert.

2 Likes

Hi Gulshan, thanks for the response. However, it’s not about being a specific query string being indexed.

For example, this is how I first encountered the issue:

I made some changes to the post, however the URL was cached and the changes didn’t reflect immeditely. To bypass this, I simply added “?random-sequence-of-letter” like “?skkjjfkjf” to the end of the URL. Whilst the page loaded, the ads were no longer visible.

As I mentioned in the above linked support thread, this same issue is being encountered on different PCs, OS’, and mobile devices.

One more thing, we tried debugging the issue after disabling the cache plugin, CF, and ad inserter pro and then manually added a single ad unit code to the HTML, and same behavior follows.

Thanks for the response @Morshii

Have you tried it for different pages (posts) whilst using some different strings at the end of the URL?

Take it lightly as it won’t affect 99.99% visitors. Because no one will add query string before visiting.

1 Like

I tried other pages and on those pages only the link ad was visible. I see no reason for this to affect your earnings. As mentioned above by gulshan.

1 Like

@GulshanKumar @Morshii Correct and correct. However, this is abnormal and shouldn’t happen now should it? If it’s acting as such, then there must be something wrong, which means it should be fixed.

I think AdSense now show advt based on the previous URL crawling. If they won’t find relevant or same URL as previous crawled chances are no advt will appear. Similarly happens for new post for some time.

1 Like

Yes it does, you’re right.

But what about others? I have checked sites of more than 20 competitors in the same niche, following the same testing on various of their pages, especially the new/latest articles. The ads appear for them, even after adding a query string to the URL.

So, why mine alone?

I could repro this happens at most popular Indian blog also which is 10+ yrs old. I have sent url in the inbox.

Consider checking in the incognito.

1 Like

I tried on on my own blog an the ads dont show up either but i am not bothered since it doesn’t affect my earnings.

1 Like

Thanks for confirming, may be it can be ignored. But what about ads on in-site search pages? Previously ads showed just fine on them, however, they are not visible now.

as @dhananjay explained already ads are not showing which has parametres like ?nocache or ?source=xxx
Same problem here. I think Google AdSense wants to show ads only on these URL which has access publicly & crawled by ads robot. And those URL with parametres will not show any ads.
Some days ago when I had changed my URL structre then it took upto 2 days to properly show ads on same pages with new URL.
(Ignore my mistakes in english if any)

2 Likes

Finally, some insight and a fellow publisher who is facing the same problem.

However, I only wonder why only a few of us (like you and me) and not everybody else is affected by this? As I mentioned in the GA support thread, I have literally scanned and tested more than 20 of my competitors for the same behavior in various scenarios:

  1. With cache and without
  2. On different posts, category/tag archives, especially in-site search result pages (That have “?s=my+search”)

I doesn’t matter how many times I tried, their ads loaded fine even when I constantly changed the query string in the URL before every reload.

It was doing fine until a few days ago, it could be a week or even more since I didn’t check my site for I was on holiday.

I wish someone comes up with some solution for this.

Now, I understood why people complain FB traffic doesn’t work for AdSense. Probably, they never see advt. Thanks to fbclid query string! I think redirecting is best option.

1 Like