Non www to www redirection on wordpress easyengine

#1

can anyone tell me which & where configuration file i should paste https://easyengine.io/tutorials/nginx/www-non-www-redirection following this instruction?

Please tell me as early as possible, I am struggling with this issue.

0 Likes

#2

This is a tutorial for NGINX, not EasyEngine documentation.

0 Likes

#3

But i was not able to find the nginx website configuration file where is kept on easeyengine server.

0 Likes

#4

Redirection of non-www to www is by default in EasyEngine

0 Likes

#5

Where is that?
Every time when i install wordpress on my website its loading with non www version.

If you know can you tell me how to do this?

0 Likes

#6

WordPress maintain www or non-www redirection itself. Just set in the WordPress setting what you need. rest, it will take care for the all “permalinks”.

0 Likes

#7

Because, you begin installing over non-www URL. That’s the reason of problem.

WordPress set HOME and SITE url as non-www, since that time in the Database table.

Solution: -


If you want www, since beginning, at 5 minutes famous installation page, you need to use “www” version.

Thanks

0 Likes

#8

I am installing wordpress

ee site create example.com --type=wp --cache

using this command on easyengine. If i change example.com to www.example.com, also website sample loading on example.com.

Please try your self following this, then please tell me how to do this.

0 Likes

#9
  1. Can you share screenshot of your WordPress general settings page?
  2. What is the Site URL?
0 Likes

#10

You will need to force redirect to WWW, there is EasyEngine option for that, I will check.

0 Likes

#11

After changing that website not opening. Getting this14 redirected you too many times error.

0 Likes

#12

Please Check,i need it.

0 Likes

#13

Is this your first time using EasyEngine? You still have time to get on Webinoly

0 Likes

#14

Sorry… I have no idea about this

0 Likes

#15

:cry:

0 Likes