SSL working for Desktop but not working for mobile?

i have installed SSL certificate from cloudflare it is showing https and secure on desktop but on mobile device chrome browser it is not working?

Because DNS cache. You may need to wait sometime.

Possible thing you can do …

  • Clear cache at chrome://net-internals/#dns
  • Change DNS using any app. This may help.
2 Likes

first, clear your browser cache and change your IP then check the problem if its not solved then install Really Simple SSL plugin and run it once I am pretty sure it will work.

Are you connected with same Wifi?

If you are using a local Internet service, the DNS changes might show some time in reflecting changes.

It happened with me a few months back. I changed some DNS settings and it was very quickly reflected on my mobile internet with Vodafone (Since it is an international company) while I switched to WiFi, based on Excitel, on same device, it took almost another 2 hours.

That’s a quite difference.

it is fixed now sir after waiting for a day

Wow. Nice.
I think it’s all because of CloudFlare cache

Hi

I installed SSL certificate on webiste from AWS Amazon load balancer. But it is showing that invalid certificate.

https://www.ssllabs.com/ssltest/analyze.html?d=oursarkariresult.in#whyNotTrusted

Please help me

This is a self-signed certificate, common name is wrong. Please check with your sysadmin.

Please check the name that you used. Fix it. You’ve entered wrong name while assigning the SSL certificate.

If that doesn’t work just use the LetsEncrypt or CloudFlare SSL.

1 Like