Unable to save Focus Keyphrase in Yoast SEO meta data

Hi Team,

Unable to save settings in Yoast SEO.

1 Like

What error you’re getting?

There is not particular save option in Yoast Plugin. It will be added automatically when you type something in that field.

But as soon as I refresh the page, the focus keyword pops out.

Again I have to type the keyword to check if everything is correct.

As you can see on snap it’s showing the focused keyword is not set as several time I typed the keyword.

This sometimes occur because of the issues with the Editor. If you are using Gutenberg change to Classic and do the test. And ViceVersa…

This same mistake I have faced in newspaper 9 theme but in that theme I have used WP Rocket & than after w3 total cache.

Suggestions is to change a theme and test again.

Troubleshooting

  • Deactivate all other plugins
  • Switch to twenty-twenty theme

Does it still happen?

Hi Gulshan,

Thank you so much for your valuable reply But today I observed some more issues related to this.

  1. Today I drafted my second article and set my focused keyword and its working fine but facing the same issue on first one.

  1. Today I set my focused Keyword on 1st article and Hit the Update. Its keeps on showing Updating at Yoast SEO section.

Don’t know what is the issue.

Thanks

Ok, do you see any error in the Browser Console (CTRL+SHIFT+J)?

Didn’t noticed. What would be the issue???

I tried on different browsers, also tried on my mobile but no luck.

What is your site URL? Without checking source code it’s hard to predict what’s happening.

Theme : Generate Press
Hosting : SiteGround
Domain : GoDaddy

Turn off Cloudflare proxy or disable firewall for path /wp-json/*