Unusual categories are indexing


#1

Hello there,
I am using newspaper 9 theme on my site then I see there are 1 category indexing 4 times with different urlsCapture

the urls are like these

https://the digital wise.com /category /top-trending /?filter_by=popular
https://thedigitalwise.com /category /top-trending /?filter_by=review_high
https://thedigitalwise.com /category /top-trending /?filter_by=featured
https://thedigitalwise.com /category /top-trending /?filter_by=popular7

search engines are indexing these pages which have option of select latest post/ best from last 7 etc what can i do please help i didnot get any help online.


#2

Check Yoast settings, title & metas, set noindex for cat.


#3

bro I am using Yoast SEO premium latest version and there is no option of title and metaCapture%203
in search appearance, there is only this option available


#4

Follow this simple guide:


#5

bro I want to index categories but want to deindex these other filter URLs which my theme is creating like above URLs example.


#6

Remove those URLs from search console and then wait… they should not be indexed in the next crawl hopefully. :thinking:


#7

arey vaaah bhai thankyou ye jo categories k filters lge hai theme mein vho index pta nii kyun ho gye isko remove kr dunga tho dubara nii honge index i hope thankyou


#8

URL Removal tool will help you. That’s a good solution.

But if the problem persists…

You can try the following in your robots.txt file

User-agent: *
Disallow: /category /top-trending /?filter_by=*


#9

Disallow directive in the robots.txt is not an ideal way for the noindex.

Pages may still remain indexed in the SERPs.

Here’s more details: https://support.google.com/webmasters/answer/93710?hl=en


#10

@GulshanKumar … thanks for pointing that out. :blush:

But what if the pages are being dynamically generated with URL parameters? Such as in-site search pages or other filtering operations.