Updrafts Creates Problem while restoring the backup

#1

Hi,
I recreated the server and restoring a backup using Updrafts plugin but It always gives following error:


I don’t know why is this happening, I have also seen this error, when I had restored the site 2 months ago and still it gives exact error and also I’m not understanding why ti backups two uploads.zip directories instead of one.
Any one can help me to understand how to fix this issue.
Thanks!

0 Likes

#3

Yes, I have not destroyed previous server, but again when I’m taking the backup it gives exact error. Previously when I had restored the backup, then it had successfully restored and now it is saying two files are corrupts but previously first upload.zip was corrupted. It is a serious issue because I didn’t know after restoring which file will be missed.

0 Likes

#5

Yes, from Google Drive.

0 Likes

#7

Restoring following full backup:

0 Likes

#9

I have successfully restored database, plugins, themes and other directories except upload. Problem always happens only with upload folder.

1 Like

#11

I don’t want to take risk, so uploading upload.zip manually. I think, I should start using another backup plugin, who knows what will happen after uploading corrupted archives.
Thanks! Hope, I will find the solution and the error will not occur in the future.

1 Like

#12

Update: I deleted all previous backups from Google Drive and re-took full site backup, Now it is not giving any error.
@anon43261443

Thanks for this, may be this is main issue, I have approx 15 backups, now reduces to 5. I hope, it will not happen again.

2 Likes

#14

Omg omg! :face_with_raised_eyebrow:
This is the same problem I also faced a few days back while I had to finish work on 25+ sites. I switched to All in One Migration, worked fine.

Other option that were in my thoughts

1 Like

#15

I tried this and worked for me:

  • I took a full backup using updrafts from old server, and then installed the plugin on the new server.

  • I restored the Database, plugins, themes, and other folders except upload.

  • After that again tried to restore Upload folder using updraft from the same backup and it worked.

I got the old answer from updraft

When, as in this case, the actual size found is bigger than that expected, the backup archive is almost certainly not corrupt. Rather, the message is triggered by having scanned the storage before the upload was complete… as a result, the archive found there is smaller than its eventual size, resulting in the subsequent message when the uploading has finished and the file is inspected again. As such, you should try proceeding with the restore, despite the message.
https://updraftplus.com/forums/topic/backup-files-in-google-drive-are-corrupt/

So finally, I have migrated to new server and restored the backup.
Thanks!

2 Likes