Why is Yoast showing my Archive pages and Tags in Google search results?

I don’t understand why Yoast SEO Plugin is still showing Tags, Archive pages, Categories on the google search result. I already have set Titles & Metas > Archives set to Disabled. But still, it’s showing in the search result.

You should use noindex meta tag.

Go to your Yoast SEO Settings and change it to “No Index”.

  1. Install and activate ‘Code Snippets’ plugin
  2. Navigate to its menu > Add a new snippet
add_filter( 'wpseo_robots', 'my_robots_func' );
function my_robots_func( $robotsstr ) {
  if ( is_page() && is_paged() ) {
    return 'noindex,follow';    
  }
  return $robotsstr;
}