Why Server Response Time Goes Slow After SSL Setup

#1

Hi Gulshaners,

My server response time was 300-600 ms. But when I installed Free SSL (Let’s Encrypt ). Server response time gone slow. Now it is 1.5-2.5 second.


Please help me.

0 Likes

#2

Can you please tell me

  • From which location you are running test?

  • Or, may be you can send me the test report link to review?

1 Like

#3

Bro, here a report link https://gtmetrix.com/reports/bloggingfirst.com/nRIrGmhL

0 Likes

#4

Are you aware that your server location is USA, and you have tested via GTmetrix with location Canada?

https://gtmetrix.com/reports/bloggingfirst.com/nRIrGmhL

Definately, way of testing is incorrect.

Solution

  • Sign in to GTmetrix, run test from USA

  • For more details, read this topic.

1 Like

#5

No I got same result in tools.pingdom.com

0 Likes

#6

It appears your site is hosted on shared web hosting. As you know shared hosting means, multiple sites would be on the same web server, in most cases it would impact.

1 Like

#7

yes sir, but when I remove SSL, I get old speed.

0 Likes

#8

6 month ago, I faced the problem. So I removed SSL. But Now due to ranking factor, I’ve installed it, but problem appear again.

0 Likes

#9

Okay dear …

Please ignore my last response

I should have asked this before. May I know how many plugins are using?

I see when I did test “readme.html” with HTTPS even, TTFB is awesome fast.
https://gtmetrix.com/reports/bloggingfirst.com/zHpaTDjh

What I understand, readme.html is a static web page, with HTTPS it is loading faster.

But, your *WordPress is slow. So, I would like to know number of plugins.

0 Likes

#10

I have installed 20 plugins

0 Likes

#11

Please make sure “Object cache” is unchecked.

See here https://bloggingfirst.com/wp-admin/admin.php?page=w3tc_general#object_cache

1 Like

#12

Ad Inserter
Akismet
All in One Schema Riche Snippets
Autoptimize
Code Snippets
Genesis enews Extended
Genesis Simple Edits
Hide Youtube Related Videos
Jetpack
Module Control for Jetpack
No self Pings
Optimize Youtube Video Embed
Really Simple SSL
Smush
Thirsty Affialiate
Tiny MCE Adavanced
UpdraftPlus
W3
Yoast
WP optimize

0 Likes

#13

oh it’s checked

0 Likes

#14

I see you are using Object cache. Please uncheck it and purge. Check load time again!

You should avoid Object cache as it is a shared host and static kind of blog not a WooCommerce site.

1 Like

#15

I have unchecked and purged

1 Like

#16

No need of this particular plugin.

https://bloggingfirst.com/wp-admin/options-discussion.php

Turn these off and done.

1 Like

#17

You do not need this.

Step 1.Keep deactivated all modules.

Step 2. For rest, using this snippet you can avoid useless CSS.

add_filter( 'jetpack_implode_frontend_css', '__return_false' );
1 Like

#18

You can avoid this. Here’s the complete guide

1 Like

#19

There is a useful thing in this plugin, if you wish you may disable Trackback for all Posts in one click by going to its settings. Later you may deactivate this plugin. Install when you need.

1 Like

#20

I would recommend replacing with “Affiliate Link Lite”. It works flawlessly.

1 Like