Yoast 10.0 has a bug, Need your support to fix


#1

Today I updated the Wordpress Plugin Yoast 10.0 and after the update, I went to edit a post.
But I can’t able to see the space to add Focus Keyword, Meta Description, Meta Title etc.
Refer to the image, and kindly help me to fix this issue.


#2

Same problem here. This problem is coming with class editor plugin. You should uninstall classic editor and check it.
Otherwise wait till next update.
I have sent a message to yoast for this. Many people has already commented same issue.
Hope they will resolve it soon


#3

Thank you so much brother! Will wait for the Update.
Only Few Sites that I manage were affected.


#4

Most welcome sir


#5

At my end, it’s working fine.

Please check console logs.


#6

@Myilraj हमारी वेबसाइट संपूर्ण रूप से कार्यरत है। कोई विघ्न नहीं आ रहा है।

Translate : My website is also working fine with both type of editors as stated by @GulshanKumar


#7

Could you explain? But when I uninstall Classic Editor, the Yoast is working fine.


#8

Chrome > F12 > Console
or, press CTRL + Shift + i and choose Console.


#9

Then try this …

  • Delete Classic Editor

  • Implement Classic Editor via below snippet

// remove block css
function remove_block_css() {
    wp_dequeue_style( 'wp-block-library-css' );
}
add_action( 'wp_enqueue_scripts', 'remove_block_css', 20 );

// disable for posts
add_filter('use_block_editor_for_post', '__return_false', 10);

// disable for post types
add_filter('use_block_editor_for_post_type', '__return_false', 10);


#10

@MyilRaj If that worked for you then please share here.


#11

I removed Classic Editor and added the script in functions.php file.
But there is no change.


#12

I am also facing same issuein my two blogs


#13

I haven’t faced such issue in any of my site. i have 8 wordpress based sites


#14

The bug is not global, but a significant part of blogs were affected.


#15

I think only few blogs are affected


#16

I have read that it has got something to do with one signal plugin. Try deactivating that and then see if the error continues.


#17

Maybe. @MyilRaj do you use OneSignal on your site


#18

The problem is not with that Plugin. When uninstalling Classic Editor, the plugin is working fine.


#19

I am using Classic Editor on all my websites. but still no issue


#20

Not all sites were affected. Even I am running and managing 10+ blogs and only 4 blogs were affected.